생성
 
태그: 모바일 편집 모바일 웹 편집
 
(같은 사용자의 중간 판 5개는 보이지 않습니다)
2번째 줄: 2번째 줄:
[[분류: IT]]
[[분류: IT]]
'''라우터'''(Rounter) 또는 중계기는 컴퓨터 네트워크에서 데이터 패킷을 중계하는 장치를 말한다. 가정용 인터넷 공유기부터 ISP(인터넷 서비스 공급자, Internet Service Provider)가 제공하는 코어 라우터까지 다양한 종류의 라우터가 있다.
'''라우터'''(Rounter) 또는 중계기는 컴퓨터 네트워크에서 데이터 패킷을 중계하는 장치를 말한다. 가정용 인터넷 공유기부터 ISP(인터넷 서비스 공급자, Internet Service Provider)가 제공하는 코어 라우터까지 다양한 종류의 라우터가 있다.
가정 환경에서는 대중적인 인터넷 공유기 한두 대로 충분하나 기업의 경우 직원들의 네트워크 트래픽 처리는 물론이고 보안 문제까지 엮이기에 전문적인 패킷 중계를 하는 라우터 장비 몇 대를 따로 사내에 들여놓는다.
[[RFC]](Request for Comments)에서 정의한 대표적인 라우팅 프로토콜 표준으로 RFC 791, RFC 922, RFC 1716, RFC 1812, RFC 2328 및 RFC 5340(OSPF 관련), RFC 1771와 RFC 4098 및 RFC 4271(BGP 관련) 등이 있다(이거 말고도 '''정말 많다'''). 이에 따라 대기업 등에서 주로 채택하는 [[IP]] 내의 라우팅 프로토콜인 OSPF(Open Shortest Path First)나 UDP랑 연계하여 포트 520으로 소프트웨어 라우팅을 하는 RIP, TCP랑 연계하여 포트 179번에서 작동하는 BGP, 시스코가 만든 라우팅 프로토콜인 IGRP와 EIGRP, IS-IS(ISP에서 주로 채택) 등이 사용되고 있다.


== 구조 ==
== 구조 ==
8번째 줄: 12번째 줄:
라우터는 제어 평면(Control Plane)과 포워드 평면(Forward Plane)에서 동작한다. 제어 평면이 통신에 적합한 외부 인터페이스를 찾아내면 그 위에 구성되는 논리 인터페이스를 다루는 포워드 평면에서 라우터에 들어온 패킷이 다시 나가게 된다.
라우터는 제어 평면(Control Plane)과 포워드 평면(Forward Plane)에서 동작한다. 제어 평면이 통신에 적합한 외부 인터페이스를 찾아내면 그 위에 구성되는 논리 인터페이스를 다루는 포워드 평면에서 라우터에 들어온 패킷이 다시 나가게 된다.


OSI 계층에 따른 컴퓨터 네트워크 이론에 등장하는 L3 스위치가 가끔 라우터와 혼동되나, 일부 기능을 PC 내 네트워크 카드 칩셋 내에서 재현할 수 있을 뿐, 패킷 중계만 하는 전문적인 라우터로 쓰기에는 뭔가 모자라다(성능, 라우팅 가능한 장치의 수, 통신 가능한 프로토콜 제약, 전력 소모량 등). L2 스위치는 중계 성능이 라우터 장비에 그나마 비빌 수는 있으나 고급 기능이 없어 효율성이 떨어지고 L4 스위치는 OSI 계층을 상당히 올라갔다 내려오기에 패킷 중계 성능과 프로토콜의 자유도가 상당히 떨어진다.
OSI 계층에 따른 컴퓨터 네트워크 이론에 등장하는 L3 스위치가 가끔 라우터와 혼동되나, 일부 기능을 PC 내 네트워크 카드 칩셋 내에서 재현할 수 있을 뿐, 패킷 중계만 하는 전문적인 라우터로 쓰기에는 뭔가 모자라다(성능, 라우팅 가능한 장치의 수, 통신 가능한 프로토콜 제약, 전력 소모량 등). L2 스위치는 중계 성능이 라우터 장비에 그나마 비빌 수는 있으나 고급 기능이 없어 효율성이 떨어지고 L4 스위치는 OSI 계층을 상당히 올라갔다 내려오기에 패킷 중계 성능과 프로토콜의 자유도가 상당히 떨어진다. 그렇기 때문에 Quality of Service(QoS) 측면에서 라우터를 사용하는 것이다.
 
라우터의 경로 제어는 인터넷 프로토콜을 중계하며 독립적인 접두사로 네트워크 상에서 표기되는 라우터 모임인 자율 시스템(Autonomous System)이 제어하는 영역에 따라 IGP(AS 내부 라우팅), EGP(AS 간의 라우팅)로 나누어 사용한다. IGP에는 RIP(벨먼-포드 알고리즘 사용)와 OSPF(다익스트라 알고리즘 사용)가 있으며 EGP는 BGP로 개선되었다.


기업의 경우 직원들의 네트워크 트래픽 처리는 물론이고 보안 문제까지 엮이기에 따로 라우터 장비 몇 대를 사내에 들여놓는다.
라우터의 트래픽 제어는 흐름 제어(반드시 ACK 신호를 받아야 통신하는 정지-대기, 사전에 최대 패킷 크기를 약속하고 그걸 넘어야 ACK를 요구하는 슬라이딩 윈도우 기법), 폭주 제어(느린 시작 및 혼잡 회피 기법에 따른 슬라이딩 윈도우 크기 조절), 교착 상태 방지가 있다.


== 종류 ==
== 종류 ==
18번째 줄: 24번째 줄:
** 센터 라우터: WAN 회선을 거쳐 회사의 본점과 회사의 지점을 서로 연결한다. 또, 인터넷 서비스 제공자와 기업의 네트워크와 연결할 때에도 쓰인다.
** 센터 라우터: WAN 회선을 거쳐 회사의 본점과 회사의 지점을 서로 연결한다. 또, 인터넷 서비스 제공자와 기업의 네트워크와 연결할 때에도 쓰인다.
** 엣지 라우터: 지점, 영업소의 네트워크를 WAN 회선에 연결하여 회사의 본점의 라우터에 접근한다.
** 엣지 라우터: 지점, 영업소의 네트워크를 WAN 회선에 연결하여 회사의 본점의 라우터에 접근한다.
* 원격 라우터: 랜과 WANG을 중계한다. WAN 라우터라고도 부른다. 브로드밴드 라우터와 코어 라우터 사이에 있다.
* 원격 라우터: 랜과 WAN을 중계한다. WAN 라우터라고도 부른다. 브로드밴드 라우터와 코어 라우터 사이에 있다.
* 브로드밴드 라우터: 가정이나 작은 규모의 기업에서 브로드밴드급의 인터넷에 접속할 때 쓰인다. 가정용 인터넷 공유기가 바로 이것이다.
* 브로드밴드 라우터: 가정이나 작은 규모의 기업에서 브로드밴드급의 인터넷에 접속할 때 쓰인다. 가정용 인터넷 공유기가 바로 이것이다.
** 핫스팟 라우터 : 휴대용 핫스팟에서 인터넷에 접속할 때 쓰인다. 브로드밴드 라우터와 결합하면 유무선 다 되는 인터넷 공유기가 된다.
** 핫스팟 라우터 : 휴대용 핫스팟에서 인터넷에 접속할 때 쓰인다. 브로드밴드 라우터와 결합하면 유무선 다 되는 인터넷 공유기가 된다.
* ISP 라우터 : 인터넷을 제공하는 제공자에 의해 접속할 때 쓰이는 라우터이다. 보통 가정에서는 ISP 라우터에서 나오는 단일 회선을 별도로 구입한 브로드밴드 라우터로 회선을 분할한 경우가 많다.
* ISP 라우터 : 인터넷을 제공하는 제공자에 의해 접속할 때 쓰이는 라우터이다. 보통 가정에서는 ISP 라우터에서 나오는 단일 회선을 별도로 구입한 브로드밴드 라우터로 회선을 분할한 경우가 많다.
다음은 OSPF가 정의하는 라우터 종류이다. OSPF에서 라우터가 연결되는 방식 및 패킷 구조는 [[wikipedia:Open Shortest Path First|여기 영문 위키백과]]를 참조하자.
* 내부 라우터(IR): 특정 지역의 라우팅을 담당한다.
* 백본 라우터(BR): '''가장 중요한 라우터''', 대부분의 라우터들을 전부 라우팅하는 핵심 라우터다. 여기가 비정상 동작을 보일 경우 네트워크가 통째로 망가진다.
* 영역 경계 라우터(ABR): IR과 BR을 중계하는 역할을 하는 라우터
* 자율 시스템 경계 라우터(ASBR): OSPF 외의 다른 프로토콜까지 쓰면서 중계를 하는 라우터.


== 제조사 ==
== 제조사 ==